[kwlug-disc] remote USB hard drive, via nfs

L.D. Paniak ldpaniak at fourpisolutions.com
Sat Dec 13 09:57:35 EST 2008

Hash: SHA1

What flavour of OS are you running on your WL500gP.  Apparently nfs
is/was broken in kamikaze (http://wiki.openwrt.org/NFS).

Maybe try shfs (ssh-fs) instead

If not kamikaze, check that everything is running:

pgrep portmap
pgrep nfs
pgrep mountd

As Paul said, send us you /etc/export on remote so we can all have a look.

Finally, the OpenWRT OS is notoriously single-user out of the box.  To
support multiple users, you really need to roll your own.  Do you have
another Linux box (or course you do!) you can try this nfs programme out on?

Good luck,

Richard Weait wrote:
> Trying to mount a partition from a USB drive via USB.  
> It's mounted, and says that it's rw
> user at local$ mount
> ...
> on /media type nfs
> (rw,addr=,nfsvers=3,proto=udp)
> but when I 
> user at local$ touch /media/touch2.txt I get 
> touch: cannot touch `/media/touch2.txt': Read-only file system
> I even chmod'ed 777 on the remote system
> user at remote$ ls -al /tmp/mnt/disc0_3/
> drwxrwxrwx    3 admin    root         4096 Dec 12 14:11 .
> and the mount point on the local system
> user at local$ ls -al /media
> drwxrwxrwx  3 root root 4096 2008-12-12 18:45 .
> I've tried with root, but expect that root_squash is blocking that.
> I've also tried with a non-privileged user with the same name and uid on
> both boxes.  
> The players in this case are
> remote: ASUS WL-500g Premium
> usb drive: WD 500GB
> local: ubuntu hardy
> So what's up with that?  Tips for nfs happiness?  
> Best regards,
> Richard
> _______________________________________________
> kwlug-disc_kwlug.org mailing list
> kwlug-disc_kwlug.org at kwlug.org
> http://astoria.ccjclearline.com/mailman/listinfo/kwlug-disc_kwlug.org
Version: GnuPG v1.4.6 (GNU/Linux)


More information about the kwlug-disc mailing list