[kwlug-disc] Adobe Flash not working on Thinkpad R31 *buntus

Charles M chaslinux at gmail.com
Mon Jul 9 16:25:19 EDT 2012


Hi all. I've been having a heck of a time getting flash to work under any
browser on most versions of *buntu since 10.04.

Normally Firefox is a simple matter of installing *buntup-restricted-extras
(which installs a whole bunch more stuff) or the flashplugin-installer
package. Even chromium-browser seems broken. Now the exact same thing works
no problem on my Lenovo 3000 C100 notebook, it just seems to be old 8MB
video RAM Thinkpads that have this problem. I've tried on a couple of old
thinkpads, an R31 and a T23 and both have the same failure.

The failure is when anything flash loads I just get a black space (no error
message on Firefox). Chromium-browser hints there's a missing plugin, but
even with all the extra chromium plugins it doesn't work either.

I've Googled the problem and tried reverting to an older version of flash,
but it didn't help. Also tried following a few [solved] where people had
the same issue, and no dice.

So one person suggested it could be the fact that the notebook may have to
be in 24 bit colour mode. Right now the R31 is running xubuntu 12.04. I did
a hwinfo --framebuffer to check the modes the notebook supports (1024x768 x
24 bit is supported). I haven't figured out how to check what mode I'm in
or switch to another mode. Normally this is editing /etc/X11/xorg.conf --
except there doesn't seem to be an xorg.conf in xubuntu 12.04; the display
configuration seems to be dynamically generated. I found the "Displays"
section in xubuntu, but bit mode is 1 thing it doesn't let you hack.

Cheers,

Charles
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://kwlug.org/pipermail/kwlug-disc_kwlug.org/attachments/20120709/b3361cbe/attachment.html>


More information about the kwlug-disc mailing list