[kwlug-disc] Ubuntu 11.04 (aka The Natty Narwhal) and LAMP

unsolicited unsolicited at swiz.ca
Sun May 1 12:22:31 EDT 2011


In general, take all internet tutorials with a grain of salt.

One of the real problems with Linux / internet documentation is 
discerning what's current and accurate and appropriate for your 
distribution.

For example, your tutorial (as I have recently discovered is true for 
zoneminder as well), dates before the standard change in directory 
usage, from, for example, /usr/share/phpmyadmin/ to /var/www/phpmyadmin/.

When looking at internet documentation, be VERY careful that you are 
following apache2, not apache documentation. Quite a bit changed 
there, and internet searches will reveal a LOT of material over the 
aggravation. Especially - newcomers being trapped by getting apache 
(apache2) from the repository, then trying to follow apache 
documentation, and ... it goes downhill from there.

In general, search the buntu wiki / documentation / forums first. It 
will be far more authoritative for distribution specific instructions, 
than the internet in general. I believe there are LAMP tutorials in there.

For your immediate problem, and in general for the quickest response, 
irc is your friend. The buntu channels, and most every other channel 
I've ever seen, are well populated with helpful people. Including, 
when on non-distro channels (assuming there is a LAMP channel 
somewhere), being multi-distro aware, and able to help with buntu 
specifics.

Which is one of the reasons to choose a buntu distribution, these days.

http://www.kubuntu.org/support
http://www.kubuntu.org/community
http://www.kubuntuforums.net/
http://www.ubuntuforums.org/
irc://irc.ubuntu.com/kubuntu

https://help.ubuntu.com/community/ApacheMySQLPHP
- reached as the first hit, searching on LAMP, at https://help.ubuntu.com/

GL&HF




John Johnson wrote, On 05/01/2011 9:54 AM:
> Linux newbie here. With a new (ram starved) box w/Ubuntu 11.04 (aka The 
> Natty Narwhal).
> 
> I was in the "Now what?" moment.
> Then a light went on. Actually a LAMP.
> 
> But I ran into a bit of trouble setting up LAMP on Ubuntu 11.04.
> 
> Thinking that 10.4 was relatively close enough to 11.04 I followed the 
> tutorial at:
> http://tuxtweaks.com/2010/04/installing-lamp-on-ubuntu-10-04-lucid-lynx/.
> 
> Everything was going fine, stepping through the tut.
> But I ran into trouble at the last section, the part where phpmyadmin is 
> installed and tested.
> It appears that phpmyadmin went into /usr/share instead of /var/www as 
> expected in the tutorial.
> And testing with a browser mapped to http://localhost/phpmyadmin/ failed.
> 
> Do I need to uninstall and reinstall phpmyadmin? how?
> 
> The Google brings up some repair suggestions like editing files such as 
> php.ini etc.
> See: 
> http://webpagedeveloper.me/blog/ubuntu-1004-lucid-lamp-server-running-php-52-and-53 
> 
> This seems overkill and more geared towards those who need to support 
> apps using earlier versions of PHP.
> I am happy with PHP Version 5.3.5-1ubuntu7.1. I do not need PHP 5.2 or 
> even PHP 5.3 (w/o the Ubuntu suffix).
> 
> I tried copying /usr/share/phpmyadmin/ to /var/www/phpmyadmin/ but this 
> was denied.
> I used sudo cp ... as well as the GUI (which does take some getting used 
> to).
> The copy operation was denied in both.
> 
> Now exploring: http://tuxtweaks.com/2009/07/how-to-configure-apache-linux/
> 
> Looking forward to your responses.



More information about the kwlug-disc mailing list