[kwlug-disc] usb modem on linux?

John Van Ostrand john at netdirect.ca
Sun Apr 4 10:45:56 EDT 2010


----- "Insurance Squared Inc." <gcooke at insurancesquared.com> wrote:

> I'm setting up a computer for my sister who lives in a rural area.  
> Couldn't get the installed modem to work, so I bought a US Robotics
> USB 
> modem.
> 
> Under mandriva 2010, I can't get this to work.  The modem is listed as
> a 
> us robotics modem under the 'unknown' category in the hardware gui, so
> 
> it seems to know that it's there.  But when I try to set up a network
> 
> connection I'm having all sorts of problems.  I've got two types of 
> connections I've tried, G3 as well as Analog phone/pots.  Under the
> G3, 
> it actually names the modem, asks for a pin number that I leave blank,
> 
> then errors out under a 'insert a sim card'.  No idea there.  If I use
> 
> analog phone, it goes all the way through, but doesn't connect. 
> (under 
> analog it asks me for the port, i.e. tty0/com1, 
> tty1/com2...../dev/modem.  And I've tried a number of them, to no
> avail). 
> 
> Any pointers on how to make linux see the modem?  I'm stumped.

Is you trying to set up a celluar modem or a analog POTS modem?

The PIN and SIM card requests suggests you are trying to set up cellular modem.

If this is an analog modem then you may need to know a few things. Hopefully you only need to know one thing, the device name. To find the device name insert the USB modem, wait a couple of seconds and run dmesg to see what device name was assigned, then use that in your dialler set up.



More information about the kwlug-disc_kwlug.org mailing list