[kwlug-disc] Any Python Experts?

Khalid Baheyeldin kb at 2bits.com
Thu Sep 13 10:38:44 EDT 2018


On Thu, Sep 13, 2018 at 10:16 AM John Driezen <jdriezen at sympatico.ca> wrote:

>
> The plotly library only works with Python 2.7, and I wrote a scraper to
> work with
> Python 3.5.
>

Plotly seems to be available for Python 3.

There is a deb package for it, at least under Ubuntu 16.04

$ aptitude show python3-plotly
Package: python3-plotly
New: yes
State: not installed
Version: 1.9.5+dfsg-1
Priority: optional
Section: universe/python
Maintainer: Ubuntu Developers <ubuntu-devel-discuss at lists.ubuntu.com>
Architecture: all
Uncompressed Size: 1,310 k
Depends: python3:any (>= 3.4~), python3-six (>= 1.8.0), python3-requests
(>= 2.3.0), python3-tz (>= 2012c)
Suggests: python3-matplotlib (>= 1.3.1), ipython3 (>= 1.3.1)
Description: Python 3 plotting library for publication-quality graphs
 Python 3 plotting library for collaborative, interactive,
publication-quality graphs. Plotly is an online collaborative data
 analysis and graphingvtool. The Python API allows you to access all of
Plotly's functionality from Python.
Homepage: https://plot.ly/python/
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://kwlug.org/pipermail/kwlug-disc_kwlug.org/attachments/20180913/741dcb42/attachment.html>


More information about the kwlug-disc mailing list