[kwlug-disc] my freedns.afraid.org venture

unsolicited unsolicited at swiz.ca
Sat Mar 22 18:22:09 EDT 2014

Hi John - what he (Bob) said.

You have at least two issues:

1. Trying to map a textual name to your public ip of that moment.

You'll know you have success when you 'nslookup {your name}' give as a 
good number, not something in the private address space. 

(Bob's stuff applies.)

2. Once getting to that -IP- ('cause dns will to a textual to ip 
translation for you), accessing a service (port) through the router at 
that IP. e.g. Using a web browser, it assumes http services are offered 
at port 80 of an IP, unless told otherwise.

You'll know you have success (don't need 1. above for this), by going to 
http://{your public ip address of that moment}. You can find your public 
ip address at the time by going to http://www.myipadddress.com (lots of 
other ways to get the same info).

- note: You must do this port forwarding on your Roger's gateway (if not 
the Rogers gateway AND your DIR. And each router points to the next one 
- so, e.g. {Rogers gateway:80} -> {DIR:80}, {DIR:80} -> {computer:80}


Lots of people do what you're doing - e.g. anyone calling ssh'ing or 
openvpn'ing in to home, so definitely doable. Although, in my case, I 
use no-ip.com or dynsns.org - didn't know about afraid.org or 
dnsdynamic.org, thank you both for that!

On 14-03-22 03:14 PM, Bob Jonkman wrote:
> Hash: SHA1
> Hi John: Is the address of the router the external (WAN) address, or
> the internal (LAN) address? nslookup tells me
>> $> nslookup tardisxl5.mooo.com Server: Address:
>> Non-authoritative answer: Name:	tardisxl5.mooo.com Address:
> If the address is your external (WAN) address then the
> problem is most likely punching a hole in your firewall for Web
> services (port 80) to get from that external address to the internal
> host providing the Web service. Look for "NAT translation" or
> "Games/Application Sharing" on the firewall.
> If is not your external WAN address then something else
> is wrong. If tardisxl5.mooo.com is not the domain name you're trying
> to acquire then I don't understand the .conf file you provided.
> FWIW, I use dnsdynamic.org, which uses the dyndsn2 protocol. My
> ddclient.conf file looks like this:
>> # Configuration file for ddclient generated by debconf # #
>> /etc/ddclient.conf
>> protocol=dyndns2
>> # use=if, if=eth0 use=web, web=myip.dnsdynamic.com        # get ip
>> from server.
>> server=www.dnsdynamic.org login=bjonkman at sobac.com password='really
>> secret password' lpr.dnsd.me
> No, KWLUG haxors, there are no useful services at that address, or
> login/PW combo.
> - --Bob.
> On 14-03-22 02:54 PM, John Kerr wrote:
>> Hi everyone
>> I have been working on this for too long with nothing to show for
>> it
>> I can't get freedns.afraid.org service to see past my router. I am
>> on Rogers as an ISP.
>> I have tried pointing to a computer on my my lan as well as
>> pointing to the router name as well. same result I can ping the
>> server but the IP that comes back is that of the router. when I try
>> to hit a web page it hangs.
>> I tried setting up freedns.afraid .org a the dns service and it
>> tells me the host is invalid. It is a dling DIR-655 Here is my
>> inadyn.conf file this one is trying to hit the name of my router
>> -username --password --update_period_sec 300 --forced_update_period
>> 21600 --alias alias
>> TardisXL5.mooo.com,Tnh6Q1JGSDFYU3pRaFh0YXVlSWE6MTEzMTY2MzI=
>> --background --dyndns_system default at freedns.afraid.org --syslog
>> that is it, exactly as shown -- less login info Any ideas? Apache
>> is working. Thanks in advance I had another file trying to point at
>> the webserver on my network that did not work either.
>> thanks
>> John
> Bob Jonkman <bjonkman at sobac.com>          Phone: +1-519-669-0388
> SOBAC Microcomputer Services             http://sobac.com/sobac/
> http://bob.jonkman.ca/blogs/    http://sn.jonkman.ca/bobjonkman/
> Software   ---   Office & Business Automation   ---   Consulting
> GnuPG Fngrprnt:04F7 742B 8F54 C40A E115 26C2 B912 89B0 D2CC E5EA
> Version: GnuPG v1.4.14 (GNU/Linux)
> Comment: Ensure confidentiality, authenticity, non-repudiability
> iEYEARECAAYFAlMt4RIACgkQuRKJsNLM5eqQiQCg8io34i7k2taDBWjyx0n86Qcd
> 6UYAnR5gGaadX80GybjohkZnKwpQB8vy
> =GhEC
> _______________________________________________
> kwlug-disc mailing list
> kwlug-disc at kwlug.org
> http://kwlug.org/mailman/listinfo/kwlug-disc_kwlug.org

More information about the kwlug-disc mailing list