[kwlug-disc] Using mSata drives

CrankyOldBugger crankyoldbugger at gmail.com
Tue Jan 14 14:53:33 EST 2014


Here's a question for the pros here...

My Lenovo laptop came with a 1TB HDD, and a 16gig sSata drive.  It
originally shipped with Windows 8 but I eventually wiped the whole 1TB and
installed Ubuntu 13.10 on it.  Runs great.

One thing I noticed is that the 16gig mSata is not being used.  I would
like to use it a my /swap partition.  As it happens, there is no swap
partition on the system.

jeff at Quorra-Ubuntu:~$ sudo fdisk -l
[sudo] password for jeff:

WARNING: GPT (GUID Partition Table) detected on '/dev/sda'! The util fdisk
doesn't support GPT. Use GNU Parted.


Disk /dev/sda: 16.0 GB, 16013942784 bytes
255 heads, 63 sectors/track, 1946 cylinders, total 31277232 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x8bb65f34

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1               1    31277231    15638615+  ee  GPT

WARNING: GPT (GUID Partition Table) detected on '/dev/sdb'! The util fdisk
doesn't support GPT. Use GNU Parted.


Disk /dev/sdb: 1000.2 GB, 1000204886016 bytes
255 heads, 63 sectors/track, 121601 cylinders, total 1953525168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0x8bb65f33

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1               1  1953525167   976762583+  ee  GPT
Partition 1 does not start on physical sector boundary.



Here's the df:

jeff at Quorra-Ubuntu:~$ df -h
Filesystem                     Size  Used Avail Use% Mounted on
/dev/sdb2                      275G  5.2G  256G   2% /
none                           4.0K     0  4.0K   0% /sys/fs/cgroup
udev                           3.9G  4.0K  3.9G   1% /dev
tmpfs                          794M  1.5M  792M   1% /run
none                           5.0M     0  5.0M   0% /run/lock
none                           3.9G  472K  3.9G   1% /run/shm
none                           100M  108K  100M   1% /run/user
/dev/sdb1                       93M  3.3M   90M   4% /boot/efi
/dev/sdb3                      642G  101G  509G  17% /home
10.42.1.95:/volume1/video      8.1T  5.4T  2.7T  68%
/home/jeff/Videos/Athenavids
10.42.1.95:/volume1/music      8.1T  5.4T  2.7T  68%
/home/jeff/Music/Athenamusic
10.42.1.95:/volume1/NetBackup  8.1T  5.4T  2.7T  68% /mnt/Athenabackups

As you can see, there is no swap partition.  I _thought_ I set up the mSata
as the swap, during the install, but apparently not.

Please note that this machine has UEFI, but SecureBoot is turned off.  Damn
Windows 8....

Does anyone have any ideas on how to set up the mSata as the swap partition?

Thanks,

Jeff
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://kwlug.org/pipermail/kwlug-disc_kwlug.org/attachments/20140114/8dd75b98/attachment.html>


More information about the kwlug-disc mailing list