[kwlug-disc] Ubuntu 11.04 and LAMP :: Problems w/ MySQL access over 'net

John Johnson jvj at golden.net
Fri May 13 20:14:33 EDT 2011


  On 2011-05-06 22:11, JohnJ wrote:
> Update: I now have [ edit ] a Linux box/web server running LAMP at 
> home mapped through my router to the 'net.

< ... snip ... >

> I will post am posting my adventures with LAMP on the my blog.

< ... snip ... >

> I deferred the FTP thing ...

< ... snip ... >

On 2011-05-02 11:10, JohnJ wrote:
> Soon:
> MySQL

So much for background.

Though LAMP I have MySQL installed.
MySQL works locally.
MySQL works through http://localhost/ see below.
*MySQL does not work through the tubes*.

And I was pleased to find that the PDO drivers came with LAMP for Ubuntu 
11.04.
(The Google said that this was a lot of work with earlier versions of 
Ubuntu & LAMP).
BTW: I have an app that uses pdo as opposed to mysqli.

A short 15 line test php file that tests access to a test db (using pdo) 
in MySQL works fine through http:://localhost/pathtotestfile

But, from another PC and coming into the same test file over the tubes 
using http:://insert-ip-address-here/pathtotestfile
I am met with: HTTP 500 : Internal Server Error.

The test file has been chmod-ed to 755.
Same result.

That other PHP files, w/o MySQL code, execute over the tubes suggest 
that MySQL is the problem.
And for some reason the try / catch in the test code is failing to to be 
gentle with the error handling.


I could crawl through the tubes looking at tuts but I thought I would 
toss this out here.

Thanks.
JohnJ

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://kwlug.org/pipermail/kwlug-disc_kwlug.org/attachments/20110513/aa541c91/attachment-0001.html>


More information about the kwlug-disc mailing list