[kwlug-disc] RPM won't install, won't uninstall

Oksana Goertzen ogoertzen at gmail.com
Fri May 13 12:11:29 EDT 2011


On 13 May 2011 11:31, John Van Ostrand <john at netdirect.ca> wrote:

> ----- Original Message -----
> > Servername :/software/lintape # rpm -e
> > /usr/src/packages/RPMS/x86_64/lin_tape-1.50.0-1.x86_64.rpm
> > error: package
> > /usr/src/packages/RPMS/x86_64/lin_tape-1.50.0-1.x86_64.rpm is not
> > installed
>
> try:
>
> rpm -e lin_tape
>
>
> --
> John Van Ostrand
> CTO, co-CEO
> Net Direct Inc.
> 564 Weber St. N. Unit 12, Waterloo, ON N2L 5C6
> Ph: 866-883-1172 x5102
> Fx: 519-883-8533
>
> Linux Solutions / IBM Hardware
>
>
I initially tried to run rpm -e but it wouldn't uninstall.
And I also tried to run rpm -Uvh and it would say it was installed.
There is a daemon that goes along with this module and it's
dependent on lin_tape, so that adds to the complexity.  It
shows the daemon as installed but won't load because lin_tape
wouldn't load.

Running rpm -e --nodeps worked.  I didn't think it did initially
because it didn't return any message... but then when I tried
rpm -qs it didn't show the files as it did earlier... so I recompiled
the module again and ran rpm -Uvh and this time it worked!

:)  Oksana
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://kwlug.org/pipermail/kwlug-disc_kwlug.org/attachments/20110513/7888eba5/attachment.html>


More information about the kwlug-disc mailing list