[kwlug-disc] Ubuntu 11.04 (aka The Natty Narwhal) and LAMP

John Johnson jvj at golden.net
Sun May 1 09:54:04 EDT 2011


Linux newbie here. With a new (ram starved) box w/Ubuntu 11.04 (aka The 
Natty Narwhal).

I was in the "Now what?" moment.
Then a light went on. Actually a LAMP.

But I ran into a bit of trouble setting up LAMP on Ubuntu 11.04.

Thinking that 10.4 was relatively close enough to 11.04 I followed the 
tutorial at:
http://tuxtweaks.com/2010/04/installing-lamp-on-ubuntu-10-04-lucid-lynx/.

Everything was going fine, stepping through the tut.
But I ran into trouble at the last section, the part where phpmyadmin is 
installed and tested.
It appears that phpmyadmin went into /usr/share instead of /var/www as 
expected in the tutorial.
And testing with a browser mapped to http://localhost/phpmyadmin/ failed.

Do I need to uninstall and reinstall phpmyadmin? how?

The Google brings up some repair suggestions like editing files such as 
php.ini etc.
See: 
http://webpagedeveloper.me/blog/ubuntu-1004-lucid-lamp-server-running-php-52-and-53
This seems overkill and more geared towards those who need to support 
apps using earlier versions of PHP.
I am happy with PHP Version 5.3.5-1ubuntu7.1. I do not need PHP 5.2 or 
even PHP 5.3 (w/o the Ubuntu suffix).

I tried copying /usr/share/phpmyadmin/ to /var/www/phpmyadmin/ but this 
was denied.
I used sudo cp ... as well as the GUI (which does take some getting used 
to).
The copy operation was denied in both.

Now exploring: http://tuxtweaks.com/2009/07/how-to-configure-apache-linux/

Looking forward to your responses.

Thanks
JohnJ





-----
No virus found in this message.
Checked by AVG - www.avg.com
Version: 10.0.1209 / Virus Database: 1500/3607 - Release Date: 04/30/11




More information about the kwlug-disc mailing list