[kwlug-disc] NFS slow ...

unsolicited unsolicited at swiz.ca
Wed May 5 03:13:35 EDT 2010


OK, but even full speed, external internet traffic shouldn't bog down
the internal network too much. A large internal file transfer machine
to machine would though. (I'm assuming you're GB internally.)

Khalid Baheyeldin wrote, On 05/04/2010 12:07 PM:
> When this was happening, I could access the internet at large with fairly
> decent speed. It was access to the NFS server that was slow.
> 
> But fibre would nice ...
> 
> On Mon, May 3, 2010 at 1:38 PM, unsolicited <unsolicited at swiz.ca> wrote:
> 
>> Any chance this was an internal network congestion issue?
>>
>> Or ... what seems to be the stock answer of most parents ... the kids must
>> have been downloading (torrenting) something.
>>
>> And they say we don't need fibre to, and through, the home! (Save us from
>> our kids?)
>>
>> Khalid Baheyeldin wrote, On 05/03/2010 11:12 AM:
>>
>>  Update:
>>> After putting the laptop to sleep and then opening it the following
>>> morning, the problem is no longer there.
>>>
>>> <shrug ...>
>>>
>>> On Sat, May 1, 2010 at 9:50 PM, Khalid Baheyeldin <kb at 2bits.com>
>>> wrote:
>>>
>>>  I am having a weird issue on our home network.
>>>> Basically, the server runs NFS. The share is accessible to other
>>>> PCs at home.
>>>>
>>>> When I browse the share for a folder containing largish pictures
>>>> (2.4 MB, thanks to a new Canon), it is extremely slow. Taking
>>>> many minutes to just display the thumbnail of the picture.
>>>>
>>>> This did not happen before. I was able to browse fine.
>>>>
>>>> Here is what netstat shows on the server:
>>>>
>>>> # netstat -tuap| grep nfs tcp 0      0 *:nfs          *:*
>>>> LISTEN      - tcp 0 850424 homeserver:nfs 192.168.0.xx:932
>>>> ESTABLISHED - udp 0      0 *:nfs          *:*
>>>>
>>>> So you can see that the server is listening, there is one
>>>> connection established from my laptop to the server, and there
>>>> are many bytes waiting to be send. The bytes disappear after a
>>>> while (when the thumbnail is displayed in Dolphin I am guessing).
>>>>
>>>>
>>>> I rebooted the laptop. Did not help. I rebooted the server. Did
>>>> not help either.
>>>>
>>>> Other than that, I am stumped as to where the issue could be.



More information about the kwlug-disc_kwlug.org mailing list