[kwlug-disc] tomtom 910 gps has linux and I'm a hackin!

Chris Bruner cbruner at quadro.net
Mon Mar 22 00:47:30 EDT 2010


So far I've been able to set up a minicom console session on the little 
guy and have been able to explore the processes and run the busybox 
commands. This involved downloaded binaries from opentom.

I've downloaded the cross compiler and tried hello world but it is 
missing the c++ libraries. (I think this will work though as it 
recognized the files as elf executable and complained in an meaningful 
manner).

http://www.fenrus.org/tomtom/ has a page on connecting to the tomtom 
where he makes your pc look like a phone. I've tried this with no 
success. (I'm hoping one of you brains can look over his page and see if 
something is missing). The tomtom doesn't doesn't see it as a phone.
The command which seems to be failing is on the PC side

dund -d --dialup --listen call tomtom connect /etc/ppp/tomtom.sh debug
dund[25150]: Bluetooth DUN daemon version 4.51
dund[25150]: Bind failed. Address already in use(98)

Any idea how I can find what address is in use? or what is actually 
going on?





More information about the kwlug-disc_kwlug.org mailing list