[kwlug-disc] KWLUG - The Kitchener Waterloo Linux User Group new content notification: 2010-08-16 21:02

webhost at kwlug.org webhost at kwlug.org
Mon Aug 16 21:02:40 EDT 2010


Greetings mail-forum-merge,

------------------------------------------------------------------------------
Recent content - 2 new posts
------------------------------------------------------------------------------

1. USB Webcam mistery under Ubuntu Lucid Linx
Published Blog entry by Raul Suarez
[ http://kwlug.org/node/759 ]

Maybe someone with better knowledge of USB can shed some light here:
I have an USB camera that I knew was working several Ubuntu versions
ago. But under Karmic and Lucid it refused to work.
I knew that it was listed as supported; but after hours trying things I
couldn't make it work.
Then I saw in a forum that someone said that as a final test he
disconnected the USB hub and plugged in the camera directly to the
computer. After that it worked, so he suspected the hub.
In my case I was connecting directly to the computer already so I
thought: "I'll try the other USB port" and the camera worked!!... For a
few minutes, then it stopped working.
So it occurred to me that the only difference was that when I switched
ports I had disconnected the USB wireless mouse.
I unplugged the mouse and voila! The camera started working under:
gstreamer-properties
cheese
ekiga
This is, everywhere, even Skype!
One clue could be that both devices (the camera and the mouse) are
Logitech so the top part of the ID is the same 046d:c50e
Bus 002 Device 006: ID 046d:c50e Logitech, Inc. MX-1000 Cordless Mouse
Receiver
Bus 002 Device 003: ID 046d:0870 Logitech, Inc. QuickCam Express
What else could it be the problem here?
Later I will try with this camera in a different computer and also with
different mouses.
Do you have any clues for me to investigate or provide better
information when reporting the issue?

---

2. Mandriva 2010 First impressions
Published Blog entry by Raul Suarez
[ http://kwlug.org/node/760 ]

A week ago someone at the KWLUG was talking about Mandriva, and I
mentioned that I never warmed up to it. 
That conversation left me intrigued so today I decided to give it a try
once again.
This will be a play by play impression while I go through the install.
Some of my comments may sound picky, but as first impressions count:
I'm all pumped up and ready to be wowed.
On inserting the disk I remembered why I hadn't been able to fully test
it: the DVD is not a live version. No live DVD. Why? Do I need to
download the CD to see if I like it and if I do then get the DVD?
-1
I decide to go with the DVD. After starting the installation, things
went smooth, until partition time. The installer took some time
analyzing if it could shrink Windows and offered me to use that space. I
guess it is a good assumption that most new users will have Windows
already installed and the people that already has Linux, will know how
to partition properly.
+1
I selected the advanced method. Selected my root partition and continued
installing until I got to a screen that asked me if I had other sources
to use. I selected HTTP to see if it would offer me additional packages,
but all that happened is that it asked me for an HTTP address. If I am
new to Mandriva, how would I know what address to use? 
-1
When it came time to select the bootloader, I decided to ignore it as I
already have Grub2 under Ubuntu Lucid.
It configured my network and asked me if I wanted to update the
packages. Wow, that's nice, Install and update all at once while I have
dinner!! I'm liking it.
+1
Things completed and I rebooted in Ubuntu to update grub. Restarted the
computer but It wouldn't boot Mandriva. It's complaining about the
root=/dev/sda6 kernel parameter.
I went to Ubuntu, created a 40 level grub2 script to manually add
Mandriva and things rebooted properly. I don't know if I should blame
grub2 or Mandriva for this one so things are still in favour of
Mandriva.
Upon download I was welcomed with the final setup, Surprise! Mandriva
selected the highest resolution available for my card and monitor, which
is 1920x1440. On a 19" monitor the text on the welcome screens were
super small and there was no way to change the resolution at that time.
-1
The welcome screen asked me to register to the Mandriva community. All
good and nice, except that it asked for an email and a password. No
indication that the password should be different than the login password
for the computer. A new user would assume that if he/she just provided a
password 3 minutes ago while installing. The password requested will be
that one.
-1
Finally I got to the login screen and to the desktop. It looks like
KDE3... wait a second, Shouldn't this be KDE4.x? Well it is, but kind of
retro. No plasma widgets, no searchable menu. Just plain retro KDE3.
Aggghh, Will need to take some time to configure it to look as a default
KDE4? bummer.
-1
OK, now it's time to finally change the resolution... Where are the
system settings? Nowhere. So I clicked some menu entries that looked
promising: "Configure your computer"... Nop, Even though it has a
hardware section, configuring the display (hardware) is not there. And
by the way, the menu entry does not correspond to the title of the
window that opens. Finally I found it under "Configure your desktop",
which had an icon similar to the "System Settings"... wait a second...
It IS the system settings. with keyboard, multimedia, network sharing.
all that, Why would they call it something different is a mystery to me.
-3 (Yes, this one was annoying)
Oh, a pop up advising me of a new version. How nice, but, didn't I just
updated during installation? whatever. 
+1 for advising me of the new version.
I'm on a roll so I say I want to upgrade. It first shows me two options
I didn't know what they meant. so I selected the one that said "download
all packages", wouldn't it be clear that if you update over the Internet
you MUST download the packages? Well... then it said that it had to
download 2.3 GB of data! Sounded like a lot to me considering that the
full DVD is less than twice that. I decline the upgrade.
-1 for the confusing wording.
I proceeded to try to find the software upgrade for the current
version... I'm searching until I find it buried under: "Configure your
computer". This is now just funny. You cannot configure your display
under the Hardware section of "Configure your computer" which has an
icon that looks like a display but somehow they think that installing
and updating software is equivalent to configuring my computer by
clicking on a "screw driver and a wrench" icon?
-2
Getting over the naming (after all What's on a name but SEMANTICS) I
proceeded to update my system. What? only 5 packages ready to update? I
thought that my version was so old that there was even a newer full
version. Until I remembered that during the installation It asked me if
I wanted to update the packages. Great something to smile about. 
+2
I click update and this message is shown: "Rpmdrake or one of its
priority dependencies need to be udpated first. Rpmdrake will then
restart". What is that Rpmdrake for and will it affect my computer if it
restarts? I guess it's not OK to continue but then nothing gets
updated... mmmm. I'll click update again and bite the bullet. Everything
seems to install and at the end another message:"You should restart your
computer for glibc" Who is that glibc and why should I restart for him?
My only option is "OK" does that mean that I have no other options?
I click OK and go for some milk while it reboots... I come back but the
computer didn't reboot. It is telling me that it needs to contact the
mirror. blah blah. I accept and I see that the Software Packages update
restarted but has a huge list of things to upgrade. Didn't I just go
through this and it was just a short list? I had even awarded 2 points
for upgrading while installing. I click "Update" again and... another
question asking me to confirm. Haven't I confirmed several times? How
many freaking times do I have to say that I want to update? I'm not
laughing any more.
Now waiting. I don't know how long because it never told me the size of
each package or the total size of the updates just that there are 663
packages to be updated.
-2 (for the points I awarded above)
-5 (for being so annoying)
While it updates I'll go browse the menu to see what's there. Alt-F1...
mm, nothing. I have KDE4 in a different computer, that opens the menu.
but not here. Check the menu settings and.. the keyboard shortcut is set
to none!
Well, then I'll switch to the KDE4 Kickoff Menu style. Good thing I know
how to do it. I unlock the widgets, right click on the menu widget and
select to switch only to be shown a red X which when hovered over tells
me that it is unable to launch the widget. So, no menu, no way to switch
back with the right click. I am forced to add the traditional menu
widget and delete the malfunctioning one.
I browse the old (windows 95 style) menu and find that some applications
have a name and a description, quite useful. But some others, just the
name. What the hell is Codeina? Is it for when I am in pain? because I
need it right now!
Sitting here still waiting for it to update. I'm starting to guess that
I would've been better off upgrading, I don't know how much it is
downloading but it seems like a lot.
Finally after what seems like an eternity it finishes, with "Problems
during installation" and a list of packages on Dependency Hell!!!. this
is a new installation, I haven't added repositories, people had told me
that RPM dependency hell was no more. This was the last drop.
Or so I thought... When I click OK, it offers me more updates which
leads to an "orphan" package, whatever that means.
Finally no more updates!!
I don't think that I will keep using Mandriva for long but if I find
something worth talking about I will amend this post.
Conclusion:
This is crazy, some parts of Mandriva treat you as if you are a total
newbie, asking confirmation after confirmation and some others treat you
as if you are a Linux expert and know what libraries are required for
what and what are the names of the applications (even though the names
are different than what shows in the menus and the window title bars).
Mandriva will tell you that it is  a modern distribution while at the
same time going out of their way to make it look old and fuggly. They
even managed to break KDE4.
Things are hidden and out of place, misnomers all over the place. I've
been a distro hooper for a while and this is the first time where I've
felt really flabbergasted.
I know that this is the free version. But many volunteers worked on it.
So, how could so many little and BIG details made it to this release?
Could it be so people go for the paid version and this is just sharing
the crumbs with the community?
This is sad. Very sad. I really expected better. Honestly.

------------------------------------------------------------------------------
Recent comments - 9 new comments
------------------------------------------------------------------------------

1 new comment attached to Blog entry posted by Raul Suarez: USB Webcam
mistery under Ubuntu Lucid Linx
   1. It could be power draw.  
A by BobJonkman
     http://kwlug.org/node/759#comment-760

---

8 new comments attached to Blog entry posted by Raul Suarez: Mandriva
2010 First impressions
   1. I may be a masochist. I just by Raul Suarez
     http://kwlug.org/node/760#comment-761

   2. OK, I deleted the ~/.kde by Raul Suarez
     http://kwlug.org/node/760#comment-762

   3. What version was your DVD? by GaryWalsh
     http://kwlug.org/node/760#comment-763

   4. OK,  I finally found and by Raul Suarez
     http://kwlug.org/node/760#comment-764

   5. I think I realized that by Raul Suarez
     http://kwlug.org/node/760#comment-765

   6. I tried to upgrade, I really by Raul Suarez
     http://kwlug.org/node/760#comment-766

   7. I haven't heard about anyone by GaryWalsh
     http://kwlug.org/node/760#comment-767

   8. I started a thread on the by GaryWalsh
     http://kwlug.org/node/760#comment-768


-- 
This is an automatic e-mail from KWLUG - The Kitchener Waterloo Linux
User Group.
To stop receiving these e-mails, change your notification preferences at
http://kwlug.org/user/28/notify




More information about the kwlug-disc_kwlug.org mailing list