[kwlug-disc] USB Webcam curious behaviour

unsolicited unsolicited at swiz.ca
Sun Aug 15 18:29:48 EDT 2010


Does anything change if you avoid the use of hubs entirely?

Raul Suarez wrote, On 08/15/2010 6:04 PM:
> Thank you,
> 
> That was the same advise as Bob's. I will try with a powered USB
> hub to see if it makes a difference.
> 
> --- On Sun, 8/15/10, Chris Irwin <chris at chrisirwin.ca> wrote:
> 
>> From: Chris Irwin <chris at chrisirwin.ca> Subject: Re: [kwlug-disc]
>> USB Webcam curious behaviour To: "KWLUG discussion"
>> <kwlug-disc at kwlug.org> Received: Sunday, August 15, 2010, 2:14 PM
>>  On Sat, 2010-08-14 at 09:20 -0700, Raul Suarez wrote:
>>> When I plug just the usb webcam it works, when I have
>> the wireless mouse plugged it stops working.
>> 
>> It could also be a power issue. From my limited understanding of
>> USB (and a quick check of wikipedia appears to confirm this), 
>> devices can accept power in 1 to 5 units of 100mA, where 500mA is
>> the maximum the bus supports. So if your camera required higher
>> power (say 4 or 5 units), and your wireless mouse dongle required
>> enough power to push them over the limit (say 2 units), there
>> would be insufficient power to run both.
>> 
>> http://en.wikipedia.org/wiki/Universal_Serial_Bus#Power
>> 
>> Usually USB ports are in pairs on the same bus. If you had four
>> ports, two would probably be on a separate bus, which should
>> allow you to run the devices together. Assuming it is a power
>> issue.



More information about the kwlug-disc_kwlug.org mailing list