[kwlug-disc] KWLUG - The Kitchener Waterloo Linux User Group new content notification: 2009-06-08 16:14

webhost at kwlug.org webhost at kwlug.org
Mon Jun 8 16:14:56 EDT 2009


Greetings mail-forum-merge,

------------------------------------------------------------------------------
Recent content - 2 new posts
------------------------------------------------------------------------------

1. Undeleting FAT Files
Published Blog entry by Raul Suarez
[ http://kwlug.org/node/650 ]

I already had a post on undeleting files from an NTFS partition. But
what if the partition is a FAT partition? Don't worry there are several
solutions that will only require you to use a handful of commands.
IMPORTANT: Do not write anything or use the partition where the delete
file is. That will increase your chances of getting your files back
I've used a couple of solutions. Both successfully but geared to two
different situations:
First one is PhotoRec
http://www.cgsecurity.org/wiki/PhotoRec [1]
That one is kind of a brute force as it just looks for files ignoring
the file directory or directory structure but it is dead easy to use.
It's done wonders when undeleting files from USB memories and camera
memories which were accidentally deleted by pressing the wrong button
in
the Camera.
The second method is great for undeleting individual files keeping the
original name
fsck.vfat -vru  
e.g. to delete a file called "importantFile.txt" that was on my home
folder which is on /dev/sda1
fsck.vfat -vru /home/rarsa/importantFile.txt /dev/sda1
I got this one from the following archive but I will repeat here in
case that page is ever gone
http://lists.slug.org.au/archives/slug/2006/05/msg00002.html [2]
Important!!!
You may want to play it safe. If you have another partition with enough
space to create a partition image where to "play" and recover the files
without touching the original you can do the following:
dd if= of=//carddump bs=1024
First figure out the name of the partition where your deleted data is.
You can do it in several ways, for example:
sudo fdisk -l
and then from the drive size you can "guess" which one is the partition
Or if the partition is currently mounted and you know the mount point
name
df -h
Then match the mount point with the partition name.
e.g.  To create on your home folder a partition image file named
"carddump"  of a camera memory which is identified as /dev/sdc1
dd if=/dev/sdc1 of=~/carddump bs=1024
After that, you can use that "carddump" file as if it was another
drive, you can mount it, read it, recover files there:
fsck.vfat -vru /mycamdir/mydeletedfile.jpg ~/carddump
You will need to do this for each file. Of course, if you are handy
enough you can create a script that automates this if you have multiple
files to undelete
If you can't remember the names of the files, you can get a rough idea
from looking at a hexdump of the fat table;
fsck.vfat -rv ~/carddump
gives me this:
First FAT starts at byte 512 (sector 1)
         2 FATs, 16 bit entries
     16384 bytes per FAT (= 32 sectors)
As the FAT directory is at the start you can browse it with:
hexdump -C ~/carddump | less
(note: filenames are missing the first letter and there is no "."
between the
name and extension, you can assign any first letter to the filename)
Once you've finished undeleting; 
mkdir ~/card
mount /home/rarsa/carddump ~/card -t vfat -o loop
Now you can navigate the "card" folder using your favourite file
manager and copy the files somewhere else.
After you are done you can either delete the memory image or back it up
in case you forgot to undelete something :D

[1] http://www.cgsecurity.org/wiki/PhotoRec
[2] http://lists.slug.org.au/archives/slug/2006/05/msg00002.html

---

2. Improving XOrg pefromance for Intel video under Ubuntu 9.04 (Jaunty
Jackalope)
Published Blog entry by Raul Suarez
[ http://kwlug.org/node/651 ]

When I upgraded from Linux Mint version 6 "Felicia" which is based on
Ubuntu 8.10 to version 7 "Gloria" based on Ubuntu 9.04 my video
performance started suffering badly. Worst of all, I couldn't watch
videos using any of the applications installed vlc, miro, gmplayer,
mythTV, Totem.
To see the kind of errors I was getting refer to my bug report [3]
What worked for me was reverting the Jaunty Xorg intel driver to 2.4 as
explained in this link
https://wiki.ubuntu.com/ReinhardTartler/X/RevertingIntelDriverTo2.4 [4]
Then I edited
xorg.conf adding the following to the "Device" section
 Option "MigrationHeuristic" "greedy"
 Option "AccelMethod" "xaa"
I don't know if changing gstreamer-properties Default output to "X
Windows System (No Xv)" had any effect but it is working so I also left
it.
Just in case you are wondering. Here is the result of "lspci -nn | grep
VGA"
00:02.0 VGA compatible controller [0300]: Intel Corporation 82865G
Integrated Graphics Controller [8086:2572] (rev 02)
So this solved it for me. I am no longer getting the error in
Xorg.0.log and my video performance is better than before. MythTV, vlc
and gmplayer work at full screen using a fraction of the CPU. Still
some
choppy video with Miro, and Totem is not displaying video but I am not
getting the error.
If I have some time I will try moving up to 2.8 as explained here:
https://wiki.ubuntu.com/X/Troubleshooting/IntelPerformance [5]

[3] https://bugs.launchpad.net/ubuntu/+source/tvtime/+bug/367546
[4] https://wiki.ubuntu.com/ReinhardTartler/X/RevertingIntelDriverTo2.4
[5] https://wiki.ubuntu.com/X/Troubleshooting/IntelPerformance


-- 
This is an automatic e-mail from KWLUG - The Kitchener Waterloo Linux
User Group.
To stop receiving these e-mails, change your notification preferences
at http://kwlug.org/user/28/notify




More information about the kwlug-disc_kwlug.org mailing list