[kwlug-disc] KWLUG - The Kitchener Waterloo Linux User Group new content notification: 2009-02-15 13:16

webhost at kwlug.org webhost at kwlug.org
Sun Feb 15 13:16:27 EST 2009


Greetings mail-forum-merge,

------------------------------------------------------------------------------
Recent content - 1 new post
------------------------------------------------------------------------------

1. Setting up Vala - Trying a new programming language
Published Blog entry by Raul Suarez
[ http://kwlug.org/node/641 ]

Here I am, trying to learn a new programming language. Actually it
feels
more like getting to know the child of an old friend. Vala is a little
bit like C but in a modern way and a lot like C# without having to
install a huge runtime when you just want a "Hello world"
If you want to learn more just go to http://live.gnome.org/Vala
I am using Mint. An Ubuntu derivative so these instructions reflect
that.
I'll first share my odyssey and then the instructions that actually
worked.
Installing Vala is very easy as it is already in the repositories.
After installation I was able to follow the tutorial..
After I installed vala I set up to try "valide" a vala specific IDE and
that's when my problems started. 
I got valide's SVN trunk version and tried to "configure" according to
the README but I was missing two libraries
- GtkSourceView http://projects.gnome.org/gtksourceview/download.html
- The vala development libraries libvala-dev
I downloaded GtkSourceView from the official repository, compiled and
installed according to the instructions.
I installed libvala-dev from the distro repository 
Tried to "configure" valide again but failed complaining about libvala
being an an older version.
Back to uninstall vala and libvala from the repositories.
Downloaded the latest vala release 0.5.6 and tried to "./configure". It
complained about configure: error: flex not found but required so I
downloaded other versions, same error. Well, apparently an undocumented
dependency.
I installed flex from the repositories.
Back to configure vala: configure: error: bison not found but required.
Another undocumented dependency
I installed bison from the repositories
Finally I was able to compile and install vala but when I tried to
compile my "hello world" I got an error loading the libraries. I
searched for a solution and found that vala must be configured with
prefix=/usr.
After uninstall, configure and compiling it again, vala passed the test
I downloaded the tar.gz source for valide and tried to compile valide
again. More problems.
I tried using different versions of vala until I finally found that the
only version it worked with is vala 0.5.1!
After that, valide compiled... but when launching gave an error finding
libraries. So, uninstall, distclean and reconfigure valide with
prefix=/usr.
Finally! everything works! so here are the steps:
Install vala
1. Install vala dependencies
sudo apt-get install flex bison
2. Download vala 0.5.1 from the official site
http://live.gnome.org/Vala/Release
3. Compile vala
tar -xvjf vala-0.5.1.tar.bz2
cd vala-0.5.1
./configure --prefix=/usr
make
sudo make install
Install GtkSourceView required by valide
4. Get GtkSourceView from the official site
http://projects.gnome.org/gtksourceview/download.html
5. Compile GtkSourceView
tar -xvzf gtksourceview-2.4.2.tar.gz
cd gtksourceview-2.4.2
./configure
make
sudo make install
Install valide
6. Get valide from the official site http://www.valaide.org/doku.php
5. Compile valide
tar -xvzf valide-0.2.0.tar.gz
cd valide-0.2.0
cp gtk+-2.0.vapi.diff /usr/share/vala/vapi
cd /usr/share/vala/vapi
patch -p0 < gtk+-2.0.vapi.diff
(note, when asked for which file to patch enter gtk+-2.0.vapi)
rm gtk+-2.0.vapi.diff
cd $OLDPWD
./waf configure --prefix=/usr
./waf
sudo ./waf install


-- 
This is an automatic e-mail from KWLUG - The Kitchener Waterloo Linux
User Group.
To stop receiving these e-mails, change your notification preferences
at http://kwlug.org/user/28/notify




More information about the kwlug-disc_kwlug.org mailing list