[kwlug-disc] remote USB hard drive, via nfs

Richard Weait richard at weait.com
Fri Dec 12 20:39:35 EST 2008


Trying to mount a partition from a USB drive via USB.  

It's mounted, and says that it's rw

user at local$ mount
...
192.168.1.1:/tmp/mnt/disc0_3 on /media type nfs
(rw,addr=192.168.1.1,nfsvers=3,proto=udp)

but when I 

user at local$ touch /media/touch2.txt I get 
touch: cannot touch `/media/touch2.txt': Read-only file system

I even chmod'ed 777 on the remote system
user at remote$ ls -al /tmp/mnt/disc0_3/
drwxrwxrwx    3 admin    root         4096 Dec 12 14:11 .

and the mount point on the local system
user at local$ ls -al /media
drwxrwxrwx  3 root root 4096 2008-12-12 18:45 .

I've tried with root, but expect that root_squash is blocking that.
I've also tried with a non-privileged user with the same name and uid on
both boxes.  

The players in this case are
remote: ASUS WL-500g Premium
usb drive: WD 500GB
local: ubuntu hardy

So what's up with that?  Tips for nfs happiness?  

Best regards,
Richard




More information about the kwlug-disc_kwlug.org mailing list